A Tutorial for Physiologically Based Toxicokinetic (PBTK) Modeling in Petri Net (PN)

Install Snoopy
Snoopy is available as a package for Windows, Linux, or Mac OS X. The screenshots used throughout this tutorial were taken from a Windows installation.
Locate and download the appropriate version of Snoopy at http://www-dssz.informatik.tu-cottbus.de/DSSZ/Software/Snoopy#downloads
Install according to the instructions on the website
Create File
Open the Snoopy application
[image: ]
Click on ‘File’ -> ‘New’
[image: ]
Click on ‘Continuous Petri Net’, then ‘OK’
[image: ]


Create Places
Places are created to store ‘Tokens’, which we use to represent the toxic compound whose flow is being modeled. Create ‘Continuous Places’ for each of the non-metabolizing compartments, arterial blood, and venous blood. Create ‘Coarse Places’ for the metabolizing compartments. Arrange the compartments in a vertical line down the center, with venous blood to the left and arterial blood to the right.
Click on ‘Continuous Place’ in ‘Graphelements’, then click on the drawing pane where you want the place positioned. Each click on the drawing window will create a new place. You may click on the selector tool (arrow) to reposition a place.
[image: ]
Click on ‘Coarse Place’ to place the coarse places in the same manner
[image: ]
Double-click on each of the places to edit the properties. Enter a description in the ‘Comment’ area and ‘Show’ it on the net.  Use the abbreviation in the ‘Name’ box, which will be used later.  Do not ‘Show’ the ‘Marking’ or ‘Name’. Leave the initial ‘Marking’ set at ‘0’.
[image: ]

You may click and drag the descriptions on the drawing pane as needed to make the PN more readable.
[image: ]
There is a ‘Layout’ window available under ‘Edit’ -> ‘Layout’ to rearrange places and transitions, but I have not found it to be useful.
[image: ]


Create Transitions
Transitions are created wherever there is movement of tokens from one place to another.  Create ‘Continuous Transitions’ between the arterial blood and each of the compartments, each of the compartments and venous blood, and wherever there is flow between compartments (ie. PPT to Kidney and RPT to Liver). In this model, which assumes that all blood flow moves through the liver, there is an exception for RPT which lacks a transition to the venous blood. Create a ‘Coarse Transition’ between the venous and arterial blood, which will be used to determine recirculation and gill flux.
Click on ‘Continuous Transition’ in ‘Graphelements’, then click on the drawing pane where you want the transition positioned. Each click on the drawing window will create a new transition. You may click on the selector tool (arrow) to reposition a transition.
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Click on ‘Coarse Transition’ to place the Gill_Flux transition in the same manner.
[image: ]
Double-click on each of the transitions to edit the properties. I entered and showed the ‘Name’ for ‘Gill_Flux’, but not for the other transitions.  In the ‘Comments’ section, I find it useful to cite the literature where I derived the equations from, without ‘Show’ing it on the screen.
[image: ]
Create Arcs
Arcs are used to define how tokens move through the net.  Arcs are positioned from a place to a transition, or from a transition to a place; they are never used between two places or two transitions. Directionality of the arc is critical for token flow.
Draw arcs from the arterial blood to each of the inbound transitions for a compartment. Click on ‘Arc’ in ‘Graphelements’, then click and drag from the arterial blood place to a transition. Each click on the drawing window will create a new arc. 
[image: ]


Draw arcs from each of the inbound transitions to its compartment.
[image: ]
Draw arcs from each compartment to its outbound transition.
[image: ]
Draw arcs from each outbound transition to the venous blood.
[image: ]
Draw arcs directing token flow from the PPT -> transition -> Kidney and from the RPT -> transition -> Liver.
[image: ]
Draw arcs directing flow from the venous blood, through the gills, and into the arterial blood.
[image: ]


Gill_Flux Coarse Transition
The coarse transitions create a subnetwork to group additional places and transitions, without overloading the top-level network.  
Double-click on the ‘Gill_Flux’ subnetwork in the ‘Hierarchy’ menu. Transitions have automatically been created from the venous blood and to the arterial blood.  We will use these transitions to model the compound being expelled from the venous blood into the water and inspired from the water into the arterial blood.
[image: ]
Create an additional continuous transition called ‘Recirc’ between the venous blood and arterial blood. We will use this to show recirculation of tokens.
[image: ]
Connect ‘Recirc’ from the venous blood to arterial blood with arcs.
[image: ]
Metabolizing Coarse Places
Like coarse transitions, coarse places create a subnetwork to group additional places and transitions, without overloading the top-level network.  Below, the kidney compartment is shown, but other metabolizing compartments should be treated similarly.
For each of the metabolizing compartments, double click on its subnetwork. Places, transitions, and arcs have automatically been created for each of the coarse places to signify the token flow moving in and out of that place.  For instance, in the kidney coarse place, there are three transitions and three places.  Two transitions are directed toward a place with arcs (inbound flow), and the third place is directed toward a transition (outbound flow).
[image: ]
For our purposes, we only need one place (ie. kidney). Delete two of the places and redraw arcs from the associated transitions, preserving directionality.
[image: ]
Add additional continuous transitions and arcs for metabolism.
[image: ]

Constant Definition
The physiological, physiochemical, and other parameters required for the mathematical calculations are declared as constants.  Further information about each of the parameters is available in the accompanying manuscript.
Double-click on the ‘Constants’ folder under the ‘Declarations’ sidebar. Click on the ‘Add constant’ button.  Fill in the fields for each parameter.  ‘Constant’ should be the abbreviation of the parameter. ‘Group’ should be left as ‘all’. ‘Type’ should normally be set as a ‘double’. Under the ‘Comment’ field, it might be useful to cite where you obtained this parameter. Under ‘Main’, the value of the parameter should be entered. Continue to ‘Add constants’ until the table contains all of the required parameters.
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Function Definition
The mathematical equations that are used to simulate the model are contained within the transitions. The equations are referred to as ‘Functions’ in Snoopy and set in the ‘Function’ tab within the transition properties.
Define transitions from arterial blood to compartments. Double-click on each transition. Click on the ‘Function’ tab. 
[image: ]
Click on the ‘Function assistant’ button. The available pre-places (places connected to the transition with an inbound arc) are listed, as well as the parameters that were defined in the constant declaration. The function for the transition between arterial blood to a specific compartment (ie. brain) is straightforward. Arterial concentration is multiplied by the blood flow to the compartment (Qb). The pre-place, Aart, is a mass unit, so it is divided by blood volume (Vblood) to calculate concentration. The formula can be entered into the function assistant as shown below.  Pre-places or parameters can be double-clicked to reduce typing and prevent typographical errors.

[image: ]


Next, define the outbound transitions from each compartment to the venous blood (excluding RPT, as discussed above).  For most of the transitions, the formula is the concentration of chemical in a compartment (Qb/Vb for the brain) multiplied by the blood flow to the compartment (Qb) and divided by the tissue/blood partitioning coefficient for the tissue (Pb). The formula can be entered into the function assistant for a specific transition as shown below.
[image: ]


In compartments where a portion of the blood flow is routed to another compartment rather than the entirety of blood flow to the venous blood, then the partial flow needs to be taken into account.  For instance, the transition between the kidney and venous blood is written as equation 1, where Qpk is the fraction of PPT blood flow which goes to the kidney rather than venous blood.
		(1)
Similarly, the transition from PPT to the kidneys is written as equation 2.
		(2)
Since the model assumes all the blood exiting the RPT goes to the liver, the transition from the RPT to liver is the same as it would be if all the blood flowed to the venous blood compartment, shown in equation 3.
		(3)
The transition exiting the liver must include the additional blood flow from the RPT, so is written as shown in equation 4.
		(4)


The functions within the ‘Gill_Flux’ subnetwork must be defined.  The open-ended transition exiting the venous blood compartment is labeled ‘Exp_Chemical’, signifying the chemical expired from the gills. The open-ended transition into the arterial blood compartment is labeled ‘Insp_Chemical’, and the transition linking the venous blood to the arterial blood is labeled ‘Recirc’ for recirculation.

The properties and function for the ‘Exp_Chemical’ transition are shown below.
[bookmark: _GoBack][image: ][image: ]
The function for the ‘Insp_Chemical’ transition is entered as follows, where ‘Cinsp’ is the concentration of chemical in the water.
[image: ]
The ‘Recirc’ transition accounts for the chemical in the venous blood returning to the arterial blood compartment.  The formula is simply the venous blood concentration times the cardiac blood flow (Qc), and is entered as shown below.
[image: ]
The final transitions to be entered are for the metabolizing compartments. A chemical that is metabolized is considered to exit a compartment, since it is no longer in its original form. Places could be created to capture the metabolites and potentially be used to generate a PBTK model for the metabolites, but that is beyond the scope of this paper. The present model contains both first order and Michaelis-Menton kinetics. For first order kinetics (ie. in the liver), the function is written as shown below, with Kl being the first order constant.
[image: ]
Michaelis-Menton kinetics are written as shown below.  The function utilizes the maximum rate constant (Vmaxl) and Michealis constant (Kml).
[image: ]


Model Simulation
Once the model is complete with all places, transitions, arcs, and constants defined, it is ready for simulation. The simulation generates a time-course data set for each of the places within the Petri Net.
Simulation-Mode is found in the ‘View’ menu or by pressing the ‘F6’ key.
[image: ]
The values in the ‘Model Configuration’ and ‘Import/Export Details’ are left as defaults.  The ‘Simulator Configuration’ menu defines the time-course for the simulation. The present model is simulated for 240 hours, therefore ‘Interval start’ is set to ‘0’ and ‘Interval end’ is set to ‘240’. The MATLAB model, from which this model was derived, generated 3916 time data points, therefore ‘Interval Splitting’ is set to ‘3916’. ‘Simulator Semantics’ and associated properties were left to defaults. The ‘ODE Solver’ and associated properties were also left at default values in the present study, but different solvers and properties could be explored in the future.
[image: ]
Double-click on the ‘Default View’ to open the simulation viewer.  The node list on the right of the screen should include all places within the Petri Net.  The ‘Edit Node List’ button may be used to ensure that all the desired places are available for viewing should places be added after initial simulation.  Places may be selected/deselected as desired for graphical viewing. Pressing the ‘Start Simulation’ button will generate the time-course graphs for the selected places.  It should be noted that the plots are shown in mass units, not concentration.
[image: ]


Time-course simulation results may be exported as a comma separated value (.csv) file for use in other spreadsheet programs.  Click on the ‘Export’ button to open the ‘Export properties’ screen. Fill in the appropriate filename or browse to the appropriate directory.  Click ‘Export’ to save the time-course data for the selected places. The output .csv file is shown below in Microsoft Excel.
[image: ]
[image: ]
Model Export
Snoopy has several options for exporting the model.
A modeler may find it useful to look at the ODEs which are generated from the Petri Net model.   This can be done with the File -> Export utility shown below. The output ODEs are also shown.  The model can be output to a variety of other formats as well.
[image: ]
[image: ]
Direct Export is accessed from the ‘Simulation-Mode’ screen under the ‘Import/Export Details’ menu.  A parsed ODE text file is generated, which substitutes values for the constants. These ODEs may be used in other solving software.  An example parsed ODE is shown below.
[image: ]
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7] PN_Trout.txt - Notepad - o
Fle Edit Fomst View Help

BAart/dt = (Aven/Vblood*Qc)+(Qu"Hater)-(Aart/Vblood*Qp) - (Aart/Vblood*Qk) -
(Aart/Vblood*QL)- (Aart/Vblood=Qr) - (Aart/Vblood*Qb) - (Aart/Vblood*Qg) - (Aart/Vblood*Qf)
dAb/dt = (Aart/Vblood*Qb)-((Ab*Qb)/(Vb*Pb))
dAp/dt = (Aart/Vblood*Qp)-(((Ap*Qp)/(Vp*Pp))*(1-Qpk))-(((Ap*Qp)/(Vp*Pp))*Qpk)
dAF/dt = (Aart/Vblood*QF) - ((AF*QF)/(VF*PF))
dAg/dt = (Aart/Vblood*Qg)-((Ag*Qg)/(Ve*Pe))
dAven/dt = ((A1*(QL+Qr))/(V1*P1))+((Ag*Qg)/(Vg*Pg))+( (Ak*(Qk+(Qp*Qpk)))/

(Vie*Pk) ) +(((Ap*Qp) / (Vp*Pp) ) * (1-Qpk) )+( (AF*QF) / (VFPF) )+((Ab*Qb) / (Vb*Pb) ) -
(Aven/Vblood*Qc) - (Qu*(Aven/Vblood) /Pbu)

dAL/dt = (Aart/Vblood=QL)+((Ar*Qr)/(Vr=Pr))-((Vmax1*AL/PL)/(Knl+(AL/(VI*P1))))- ((AL*(QL
+Qr))/(V1*P1))-(A1/(V1*P1)*K1)

dAr/dt = (Aart/Vblood*Qr)-((Vmaxr*Ar/Pr)/(Knr+(Ar/ (Vr*Pr))))-((Ar*Qr)/ (Vr*Pr)) - (Ar/
(Vr*Pr)*Kr)

dAk/dt = (Aart/Vblood*Qk)+(((Ap*Qp)/(Vp*Pp))=Qpk)-( (Ak*(Qk+(Qp=Qpk)))/(Vk*Pk))-(Ak/
(Vi*Pk)*Kk) - ((Vmaxk*Ak/Pk) / (Kmk-+(Ak/ (Vk*Pk) ) ) )
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) parsed-ode.txt - Notepad - o X

Fle Edit Fomat View Help
dAart/dt = Aven/0.0042+0.2818+33.14-Aart/0.004270.0154-Aart/0.0042%0. 00814
Aart/0.0042*0.169-Aart/0.0042+2.82e-05-Aart/0.0042+0.0632-Aart /0. 00420 . 000507 -
Aart/0.0042%0.0255

dAb/dt = Aart/8.0842*2.82e-85-Ab*2.82e-05/0.00151848
dAp/dt = Aart/8.0842*0.169-Ap*0.169/0.117012*8.4-Ap*8.169/0.117012%0.6
dAF/dt = Aart/0.0842+0.0255-AF*0.0255/0.880704

dAg/dt = Aart/8.0842+0.080507-Ag*0.000507/0.00037558

dAven/dt = Ab*2.82e-
05/0.00151848+Ap*0.169/0.117012+0. 4+Ak*0.1168/0.00254064+A1*0. 07134/0. 00814728+AF*0.0255/0
.880704+Ag*0.000507/0.00037558-Aven/0.0042+0. 2818-1.657*Aven/0.0042/665.22

dAl/dt = Aart/0.0842+0.08814+Ar*0.0632/0.0692332-A1%0.07134/0.00814728-
6798*A1/4.98/3050+A1/0.08814728-A1/0.08814728+0. 038

dAr/dt = Aart/8.0842*0.0632-Ar*0.8632/0.0692332-3395*Ar/8.69/1525+Ar/0. 0692332
Ar/8.8692332%0.0189

dAk/dt = Aart/8.0842*0.0154+Ap*8.169/0.117012*0.6-Ak*0.1168/0.00254064-
Ak/8.00254864*0.023-12400Ak /2. 37/5582+Ak /8 . 08254064
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